Case Colt Ingersoll Tractors banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi folks,
After replacing the hydraulic motor, everything was working well. THEN Onan engine decided to not start or rather spin and almost start but not start. I put a new fuel filter on, new fuel pump [after market electric]. Seems to be getting plenty of fuel at carb. Took the top off carb and cleaned with cleaner and checked float level. Checked spark with timing gun and spark appears to be fine. I can get to spark but runs less than a minute and shuts off. Running throttle by hand does not seem to speed idle. Any ideas. I don't have the space, ability, or inclination to do major engine work. Would be willing to transport it to an expert if there is one in southern Minn. Thanks again dlj
 

·
Senior Member
'68 - Case 155, '73 - 646a
Joined
·
1,904 Posts
Weak condenser or points are a place to look. might also compression test both cylinders and see what that turns out to be., Trying to time the engine in a 646 is a PITA as its almost impossible to see the timing marks.

it is actually fairly easy to get hte manifold OFF the engine so you can PROPERLY clean the carb.. You will have problems until you are able to put the carb in a cleaning bucket. How 2: Pull the manifold 2 be able 2 Service the...
 

·
Administrator
Joined
·
6,178 Posts
Was it running fine prior to pump replacement? Nothing hydraulic wise under load that you know of?
 

·
Registered
Joined
·
352 Posts
Don't know if you tried this...it happened to me.....Make sure your hydraulic PTO is not engaged. I fought VERY similar issues, and once I disengaged it, it ran perfect, and I feel like a fool for not seeing it. ------Metalguy
 
1 - 4 of 4 Posts
Top