Case Colt Ingersoll Tractors banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hello got a 1977 446 18hp onan runs fine for 15mins then quits ,cools down samething ,put new gas line on with electric fuel pump looks like it has air bubbles in the filter when its running . has new float,when it quits id pull the top off the carb and the float bowel would be emty.has any one experinced this thank you
 

·
Tractor Whisper
Joined
·
3,703 Posts
There small strainer in fuel tank that need take pliers destroy this at sometime in future.

Problem you describe not run after 15 minute then no fuel (gas) caused by tank cap not venting replace cap it run all day.

You can take cap apart clean all holes out the best new cap I switch caps with Hydraulic at lease once a year there same.
 

·
Registered
Joined
·
2,348 Posts
jf446 said:
hello got a 1977 446 18hp onan runs fine for 15mins then quits ,cools down samething ,put new gas line on with electric fuel pump looks like it has air bubbles in the filter when its running . has new float,when it quits id pull the top off the carb and the float bowel would be emty.has any one experinced this thank you
I believe this is mandatory for all Unserviced Onan Owners.

Gator has you covered for a place to start. :thumbsup:

If it were mine I would disconnect the fuel line between the new? electric pump and the carb. Turn on the key and let the fuel pump drain the tank while watching with a flashlight in the tank :thumbsup:

I would search the old messages and the Faq's for Manuals and other info.

Good Luck on your Diagnostic Travels :thumbsup: :thumbsup:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
thank you every one for all the info ,still dont know if i got it , first i thought it was coil put new on ,then electric fuel pump 1.5 -4.0 psi napa mounted it under tractor to the back tucked up as high as could ,took gas tank out and screen replaced all gas line with new,and clamps with new filter .also new brass float,still quit so i took the carb apart again and took the reed valve out for the intake side of fuel adjusted the float to 1/8 .seems run ok but have not had a chance to run it for long .got a nikki carb but dont know if i want to or not the top is different size for air filter.thinking of pulling the intake off and cleaning .let you all know it turns out .thanks again j446 :usa:
 

·
Banned
Joined
·
12,618 Posts
There is always the possibility that your engine is overheating badly due to a number of issues. You may find it necessary to remove all of the engine tin to see if rodent nests are blocking air flow over the cylinders. The fins on the cylinders should be scraped clean. The valve lash should be checked and adjusted to make sure the valve timing is correct and the points should also be cleaned and reset. If the split intake manifold has developed a leak at the joint, then that will cause a "lean" condition with the fuel mixture. Sometimes, it is not just ONE thing but a combination of several minor issues that create the condition you describe. You obviously have a good handle on how to go about this and understand that it's a process of elimination to zero in on the true cause or causes. All we can do is point at different known issues and then let you bang away at them. Good Luck.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
:sm :trink: ile: well i think i got it fixed ,reset the float to 1/8 ,and took out the reed value out of the carb/plate .wraped the gas line with heat resistent wrap and seems to run fine need to check valve lash to make sure every thing is ok.thanks to a really good web site and the help from the members . :usa: thanks again jf446
 

·
Registered
Joined
·
3 Posts
Re: case 446 change gas

jf446 said:
hello got a 1977 446 18hp onan runs fine for 15mins then quits ,cools down samething ,put new gas line on with electric fuel pump looks like it has air bubbles in the filter when its running . has new float,when it quits id pull the top off the carb and the float bowel would be emty.has any one experinced this thank you
You may need to go one octane higher on the gas. I had the same problem with winter gas in the spring..Changed to higher octane works fine .. Bob Van Zandt
 

·
Registered
Joined
·
1 Posts
Stewart said:
jf446 said:
hello got a 1977 446 18hp onan runs fine for 15mins then quits ,cools down samething ,put new gas line on with electric fuel pump looks like it has air bubbles in the filter when its running . has new float,when it quits id pull the top off the carb and the float bowel would be emty.has any one experinced this thank you
I believe this is mandatory for all Unserviced Onan Owners.

Gator has you covered for a place to start. :thumbsup:

If it were mine I would disconnect the fuel line between the new? electric pump and the carb. Turn on the key and let the fuel pump drain the tank while watching with a flashlight in the tank :thumbsup:

I would search the old messages and the Faq's for Manuals and other info.

Good Luck on your Diagnostic Travels :thumbsup: :thumbsup:
Make sure BRASS has flow, not unique nasty design. ARE you SURE not a ignite issue?
 

·
Banned
Joined
·
1,351 Posts
He did say the bowl was empty.

I would do the whole cab myself. I did mine and it runs perfect. You need to do the needle valve and the high and low jets. It all comes in a kit. Stick wire in every passage and use carb cleaner.

The fact that you did a fuel pump most likely means the main/needle float was not letting fuel in all along. You may be fine with the stock fuel pump with a rebuild.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top