Case Colt Ingersoll Tractors banner
1 - 10 of 10 Posts

· Registered
'73 220, '74 646
Joined
·
54 Posts
Discussion Starter · #1 ·
Got a 646 yesterday. With 3pt reversible pto and a tiller. PO said last he knew the hour meter worked showing 200hrs on 73 or 74 could only remember first 3 of serial number. He hadn't started it in couple of years. It developed a real bad hydraulic leak in the area of the pump. Only thing I've seen that somebody hacked up is they welded pins on the tiller to mount it on the 3pt and someone did real bad job of trying to paint it all red, it has mostly wore off. It even has the tower cover. I'll try get some pics today
 

· Registered
'73 220, '74 646
Joined
·
54 Posts
Discussion Starter · #2 ·
Got some pics. It's ugly. It has a homemade sleeve hitch adapter they didn't even attempt to make look good. Got it making spark but it'll only kinda try to start. Not sure I'm reading the timing marks right.
 

Attachments

· Senior Member
'68 - Case 155, '73 - 646a
Joined
·
2,079 Posts
Well, It seems I cannot send a Private message to you.. Can you check your profile settings and make sure members can 'Start conversations with you':

Font Rectangle Pattern Music Number


Click on your picture, upper right, Select Account Settings from the list and then 'Privacy' in the list on the left..

Thanks.. Then I can send you the links in a PM. So I don't clog up this thread with all of that.

I'd appreciate that. Haven't dealt with the loader or Onan before.
 

· Registered
Joined
·
366 Posts
Got a 646 yesterday. With 3pt reversible pto and a tiller. PO said last he knew the hour meter worked showing 200hrs on 73 or 74 could only remember first 3 of serial number. He hadn't started it in couple of years. It developed a real bad hydraulic leak in the area of the pump. Only thing I've seen that somebody hacked up is they welded pins on the tiller to mount it on the 3pt and someone did real bad job of trying to paint it all red, it has mostly wore off. It even has the tower cover. I'll try get some pics today
Ones thing to check, is to be sure the hydraulic PTO is in neutral when trying to start it. I made the mistake of trying to start mine, not realizing that it was engaged, and it was no end of frustration.
Metalguy
 
1 - 10 of 10 Posts
Top