Case Colt Ingersoll Tractors banner
1 - 4 of 4 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter · #1 ·
I recently rebuilt K321 kohler (rebored at machine shop). Engine has less than 4 or 5 hours on it since rebuild. Yesterday I tried to start her up and found blown fuse. New fuse.. started up but seems like the engine is missing or something. I have now gone thru three fuses. Since rebuild of engine I had to reset the valve / tappet clearence twice, they were way off... not even close to specs when I opend up breather. Whats causing valve / tappet clearances to move and why am I blowing fuses?
 

·
Registered
Joined
·
2,052 Posts
Make sure you did not pinch any of the wiring when you reinstalled your engine. ALso look closely at the wiring harness going to the headlights. If any wire is shorted to ground then you will blow the fuse.
 

·
Tractor Whisper
Joined
·
3,703 Posts
Tell store about rebuild what was done with cam and lifters if used old lifter on new cam old lifters have wear that match lobe if swap cam go flaking off that start excelorated wear cam lifter only good lube when engine rpm's above 2,000. There no outside remedy pull cam lifters install new soon solvent clean all inside parts blow dry with air block include.
Lifter wear in center not outside edge flake cam if mismatched.
 

·
Registered
Joined
·
275 Posts
Discussion Starter · #4 ·
Update - All wires look good, found the wire to the generator on the field terminal side loose, the stud terminar is stripped, took generator apart and found the plastic insulated bushing inside is busted causing the stud to be loose as well. Could that be causing the fuse to blow?/ AND DOES ANYONE HAVE STUDS AND BUSHINGS for the both the armature and field side terminals for sale??
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top